Voicelive play GTX White/blue screen After firmware upgrade fail

  1. #1 by Fabio Luigi Bonezzi on 04-24-2018
    Fabio Luigi Bonezzi's Avatar
    Posts: 6

    Voicelive play GTX White/blue screen After firmware upgrade fail

    Hi everybody.
    I've try ti upgrade my GTX with voicesupport 1 (i have a Mac that can't Run new version 2).
    After flashing, the machine doesn't reboot and when i restart it, starts always with White/blue screen.

    I've try with a PC, voicesupport2 reconize GTX but i can't click firmware.
    It said that MIDI is already in use, i've try the utility from voiceeditor site but nothing to do.

    I've download MIDIOX and i try via sysex, the machine start to flash, but never finish.
    I've use two different firmware files, the build 25 1.0.00 & the build 50 1.2.03, but nothing.

    I Hope You Can help me, because the pedal 5 minutes before the upgrade was perfect.
    Thanks a lot.

    Fabio
  2. #2 by VoiceLiveEditor on 04-24-2018
    VoiceLiveEditor's Avatar
    Posts: 134
    Hi

    The firmware sysex file that voicesupport downloads cannot be sent to the gtx with an external midi utility.

    Voicesupport sends additional code ( header info ) to the GTX before it sends the content of the firmware file.

    Hopefully Spencer can jump in with the extra sequence of data that needs to sent to gtx before you send the firmware; or Spencer may have a firmware file that has the additional header code added(this may be an older firmware but if ressurects your gtx, you can then apply the latest firmware after)

  3. #3 by Fabio Luigi Bonezzi on 04-24-2018
    Fabio Luigi Bonezzi's Avatar
    Posts: 6

    Thanks a lot!!

    oh my god incredible!!!!!!
    I wait the file and the procedure.
    This is my email bonezzifabio@gmail.com
  4. #4 by Fabio Luigi Bonezzi on 04-25-2018
    Fabio Luigi Bonezzi's Avatar
    Posts: 6

    Answer

    Hi i received and answer with attached file

    This the file in attachment: voicelive play Gtx 1.2.10 build60 MIDIOX.syx

    I've tried to upload it but the device, flashing lights but never stop and reboot.
    How Can Spancer go in my device to recover it? Via voicesupport? Do You Need the serial Number and i've got to connect It in a moment that we decide together?
    Thanks

    Fabio

    Last edited by Fabio Luigi Bonezzi; 04-25-2018 at 10:59 PM.
  5. #5 by Paul Vannatto on 04-25-2018
    Paul Vannatto's Avatar
    Posts: 9,979
    Hi Fabio,

    I edited your last post, removing the communication from staff which is not allowed according to the Forum Etiquette rules (see last paragraph https://forum.musictri.be/showthread...orum-Etiquette)

    __________________________________________________ _______________________
    For additional help please refer to the X32 wiki pages for updated and current documentation about the X32.

    For official technical and warranty support for your product you should contact the support team through their CARE department. You can contact CARE by phone at (+1) 702-800-8290 for the US and Canada and (+44) 1562 732290 in Europe.

    You can also contact CARE via email at CARECREA@music-group.com. They strive to respond to emails within 24-48 hours during normal business hours, but please be patient if it takes longer due to the volume of emails they receive.


    Paul Vannatto
    Volunteer Forum Community Moderator
  6. #6 by Fabio Luigi Bonezzi on 04-25-2018
    Fabio Luigi Bonezzi's Avatar
    Posts: 6
    Ok good.
    Sorry i didn't know this rule.
  7. #7 by Fabio Luigi Bonezzi on 04-26-2018
    Fabio Luigi Bonezzi's Avatar
    Posts: 6

    Recover via voicesupport?

    Hi VoiceLiveEditor,
    how can we recover my GTX in that modality that you wrote me?
    I wait an answer.
    Thanks

    Fabio

    Last edited by Fabio Luigi Bonezzi; 04-26-2018 at 06:31 AM.
  8. #8 by Spencer Larsen on 04-27-2018
    Spencer Larsen's Avatar
    Posts: 439
    Hey Fabio,
    Sorry to hear you're having issues with your Play GTX, hopefully I can help!

    Have you tried a factory reset? If you hold the "Back" and "Store" buttons while you power on the Play GTX, that will induce a factory reset procedure that will [usually] recover the firmware (albeit back to an earlier version). Give that a try first, since it's way easier than doing an update over MIDI. However if that does not work, it'll be time to try it the hacky way...

    You've got a syx file of build 60 which is great, let's try to force that into the GTX. Firstly, this process is over USB (it's MIDI messages we're working with but they're sent to the USB port, not the 5-pin MIDI port) so can you please confirm that MIDI OX is seeing the GTX as a device when you connect the USB to your computer? If so, we should be good to give this a shot. So first you have to put the GTX into a weird mode, basically a "get ready to accept firmware" state, and then you can send over the firmware. Power on your GTX, connect it to your computer, then use MIDI OX to send the GTX the following messages one at a time...

    F0 00 01 38 00 6A 7E 01 00 00 00 00 00 00 00 00 F7

    ...and then...

    F0 00 01 38 00 6A 7E 7E 00 00 00 00 00 00 00 00 F7

    ...and THEN you can send it the syx firmware file. Send the firmware also using MIDI OX, not VoiceSupport. When you send the GTX those two weird messages, it won't really give you any indication on the device that it worked, but once you start sending it the firmware it'll start blinking. When the transfer is complete, the GTX will reboot itself and should happy and healthy. I just tried this process on a Play GTX here and it worked like a charm, so hopefully that works for you too! If it doesn't, please describe your GTX's symptoms. Good luck!

    Spencer Larsen
    Engineer, Testing
    TC-Helicon,
    MUSIC Group
    Our Support Team is always available for more urgent assistance.