UMC404HD Computer Monitoring Issue

  1. #1 by Alex Wu on 03-23-2018
    Alex Wu's Avatar
    Posts: 10

    UMC404HD Computer Monitoring Issue

    Hello!

    I recently got a UMC404HD so I can use my XLR microphones to record audio/talk on Discord with higher quality. I wanted also to use it to listen to my computer's audio, but there an issue: it for some reason doesn't output like I expect it to.

    Here's what's going on:
    1. It seems like certain sounds like Bass and Solo lines in a song are being lowered dramatically and have this echo effect.
    2. If I go into the UMC Audio Control Panel and lower either slider on the middle "Out1 Out2" column, the solo returns, but as you'd expect it lowers the instruments that only output on one side. If a background guitar is output on the left channel, for example, lowering the left channel slider will bring the solo back to normal volume, but lower that background guitar.
    3. Many audio sources also sound distorted.

    Is there some way to make the UMC404HD monitor exactly what the computer outputs? I apologize as I have no idea what I'm doing.

    Thank you,
    Alex
  2. #2 by Ken Mitchell on 03-24-2018
    Ken Mitchell's Avatar
    Posts: 1,306
    - Alex Wu wrote View Post
    Hello!

    I recently got a UMC404HD so I can use my XLR microphones to record audio/talk on Discord with higher quality. I wanted also to use it to listen to my computer's audio, but there an issue: it for some reason doesn't output like I expect it to.
    Hi Alex,

    Welcome to the forums. You don't say what platform you are running on but based on you mentioning UMC Audio Control Panel, I'l assume it's Windows. Hopefully, it's Windows 10?

    The Behringer driver package for the UMC series installs two distinct drivers for Windows; the WDM/WASAPI and the ASIO drivers. You can use either but you need to be careful if you are using both at the same time since they are both controlling the same audio interface. In addition, one doesn't know about changes done by the other since ASIO bypasses the OS completely.

    Here's what's going on:
    1. It seems like certain sounds like Bass and Solo lines in a song are being lowered dramatically and have this echo effect.
    What DAW are you using? Also, You should be using the ASIO drivers when working with a DAW. It also sounds like you might be double monitoring. Where are you hearing the echo? At the headphone jack? Try rotating the "Mix" knob fully clockwise to the "PB" setting.

    2. If I go into the UMC Audio Control Panel and lower either slider on the middle "Out1 Out2" column, the solo returns, but as you'd expect it lowers the instruments that only output on one side. If a background guitar is output on the left channel, for example, lowering the left channel slider will bring the solo back to normal volume, but lower that background guitar.
    This sounds like you aren't using the ASIO drivers. You should be making all of your adjustments in your DAW, not using the UMC ACP.

    3. Many audio sources also sound distorted.
    This sounds like a bitrate issue or a driver bitrate conflict. Playing a 44.1khz sample at 48khz can cause this, for example.

    Is there some way to make the UMC404HD monitor exactly what the computer outputs? I apologize as I have no idea what I'm doing.

    Thank you,
    Alex
    I use the 404HD as an output monitor on a regular basis without issue so I'm sure we can get you working.

    Ken

    -------------------------------------------------------------------
    If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
  3. #3 by Alex Wu on 03-24-2018
    Alex Wu's Avatar
    Posts: 10
    Ken;

    I am using Windows 10, but I'm not sure what you mean by WDM/WASAPI and ASIO, as I know nothing about the technology. Is it something I can switch between? How do I know they're even active?

    I just want to output things like Youtube using the UMC404HD, I'm not using a DAW to record anything just yet.
    Though, just to be clear, an example of a DAW would be Audacity, right?

    As for your questions:

    1. I'm not sure what you mean by "where are you hearing the echo", but I turned the Mix knob to PB and all that did was make the headphone output louder.

    2. I'm not using a DAW, so I was messing with the settings in Window's Sound panel, but I got frustrated and reset them back to default, only changing the output Hz with what it says in the UMC Control Panel.

    Thanks,
    Alex
  4. #4 by Ken Mitchell on 03-25-2018
    Ken Mitchell's Avatar
    Posts: 1,306
    Hi Alex,

    See my comments inline.

    - Alex Wu wrote View Post
    Ken;

    I am using Windows 10, but I'm not sure what you mean by WDM/WASAPI and ASIO, as I know nothing about the technology. Is it something I can switch between? How do I know they're even active?
    WDM/WASAPI (Windows Drive Model/Windows Audio Session API) is the built-in Window audio subsystem. This is what most programs talk to by default when running on Windows. Many DAWs (Digital Audio Workstations) support both WDM/WASAPI and what is called ASIO (Audio Stream Input/Output) which is a driver model that bypasses the Windows OS all together. Only in a DAW can you select between the drivers since most other Windows programs only use the OS sound drivers.

    I just want to output things like Youtube using the UMC404HD, I'm not using a DAW to record anything just yet.
    Though, just to be clear, an example of a DAW would be Audacity, right?
    OK, It should be easy to set up the 4040HD as your default playback device.

    Yes, Audacity is an example of a DAW but it happens to be one of the few that does not support ASIO due to licensing issues.

    As for your questions:

    1. I'm not sure what you mean by "where are you hearing the echo", but I turned the Mix knob to PB and all that did was make the headphone output louder.
    Are you hearing the echo at the headphones of the 404HD?

    The "mix" knob controls the "blend" of how much signal is coming from the 404HD analog inputs vs how much is coming from the USB 1/2 inputs into the MON (headphones). Note it only affects USB1/2 (MON A) so outputting to USB3/4 and selecting MON B on the 404HD will take that knob out of the picture.

    The signal got louder because you adjusted it from center (50%) to full PB (100%) of the USB 1/2 signal.

    2. I'm not using a DAW, so I was messing with the settings in Window's Sound panel, but I got frustrated and reset them back to default, only changing the output Hz with what it says in the UMC Control Panel.

    Thanks,
    Alex
    OK, Let's get the 404HD set up as your default audio device.

    1. Close down all applications so that no other app is fighting with us over audio settings.

    2. Open up the UMC ACP and click on the "Status" tab. Note the Current Sample Rate which is probably 48000 Hz.

    3. Right-click on the speaker in the system tray and select "Playback Devices"

    4. Click on the 404HD and click "Set Default".

    5. Click on "Configure".

    6. Under "Audio Channels" select "Stereo" and press "Test".

    You should clearly hear the test tones in the left followed by the right ear of the headphones attached to the 404HD. You may have to turn up the volume knob for the phones.

    7. Click "Next" and check "Front left and right" under Full-range speakers.

    8. Again, click on each speaker individually to make sure you still hear the test tones.

    9. Click "Next" and the click "Finish".

    10. Now, Click "Properties", "Advanced" tab, and under Default Format, set the depth and bitrate to 24 bit, 48000 Hz (Studio Quality), and click "Apply". Now click on "Test" and you, once again, should hear the test tones in the headphones.

    Bring up YouTube, play something, and adjust volume from within YouTube or use the headphone volume knob on the 404HD. No need to mess with the UMC ACP levels.

    Let me know what questions you have.

    Ken

    -------------------------------------------------------------------
    If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
  5. #5 by Alex Wu on 03-25-2018
    Alex Wu's Avatar
    Posts: 10
    I set up the UMC404HD as you told me, though the UMC Control Panel told me to use 44.1kHz so I went with that. I still hear this "echo" (I think in the headphones) and I'm not entirely sure why. I'll upload what I'm trying to say, might be easier for you.

    Here's the original song: https://www.youtube.com/watch?v=aMidO7tJPBc

    And here's what I hear: https://drive.google.com/open?id=1xm...50xCtrlS6NxT1U

    Sorry if this is too much trouble
  6. #6 by Ken Mitchell on 03-25-2018
    Ken Mitchell's Avatar
    Posts: 1,306
    - Alex Wu wrote View Post
    I set up the UMC404HD as you told me, though the UMC Control Panel told me to use 44.1kHz so I went with that. I still hear this "echo" (I think in the headphones) and I'm not entirely sure why. I'll upload what I'm trying to say, might be easier for you.

    Here's the original song: https://www.youtube.com/watch?v=aMidO7tJPBc

    And here's what I hear: https://drive.google.com/open?id=1xm...50xCtrlS6NxT1U

    Sorry if this is too much trouble
    Hi Alex,

    Never be sorry for having questions and needing a little help. For the bitrate of the interface, the UMC ACP only shows the status of what it is currently set to, not what you are to set it to. In other words, Windows Payback Settings tell the driver what bitrate to use.

    Try this... Open up the UMC ACP and then open up Playback Devices, Speaker Properties, Advanced. Set the Default Format to 24 bit, 48000 Hz and click on "Apply". Then click the "Test" button and see if the Current Sample Rate on the UMC ACP Status changes to 48000 Hz. It should.

    OK, Now on to the song URL and test.wav file. The song plays fine in my setup. The recording you made only has audio on the "left" channel. See attached image. What did you use to make that recording?

    We're getting closer.

    Ken
    Attached Images Attached Images

    -------------------------------------------------------------------
    If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
  7. #7 by Alex Wu on 03-25-2018
    Alex Wu's Avatar
    Posts: 10
    Oh boy, more issues came up.

    Trying to set the UMC404HD's sample rate to 48000Hz . I clicked test to play the sample tone and... nothing. Nothing happened. I tried playing music, the music doesn't even play. The progress bar doesn't even move. What's worse is that in the UMC Control Panel it doesn't change off of 44100Hz.

    I've uninstalled and reinstalled the drivers, restarted my computer, and disabled other audio playback sources in Windows's sound panel, like my computer monitor and disconnected bluetooth speakers.
  8. #8 by Alex Wu on 03-25-2018
    Alex Wu's Avatar
    Posts: 10
    Oh, and I'm not sure why audio is only on the left channel. I used Audacity to record that test file.
  9. #9 by Ken Mitchell on 03-27-2018
    Ken Mitchell's Avatar
    Posts: 1,306
    Hi Alex,

    It sounds like you have an application that's locking the sample rate to 44.1khz. Do you have any kind of audio re-direction or similar software installed? Something like Jack Audio Connection? I know my son had some audio problems while trying to use a "steam link" box for streaming video games.

    I'm a little confused with how you have things connected up. You said you used Audacity to record that test wave file. What was the cabling?

    As I understand the signal flow in your setup it's a Youtube video playing to the USB OUT1/2 of the 404HD being monitored at the headphone jack of the 404HD. With that signal flow how did you record the test file with Audacity?

    Ken

    -------------------------------------------------------------------
    If you want "Loud", then run a piece of sheet metal through a table saw. --Ivan Beaver
  10. #10 by Alex Wu on 03-27-2018
    Alex Wu's Avatar
    Posts: 10
    I was able to set it to 48 kHz, but now it sounds even worse; imagine the test file I sent you but now with distortion. Was setting this thing up this bad for you?

    I was able to record the test file with an XLR microphone. I placed the headphones right up to the microphone and recorded that through Audacity. I think it came out only on the left sound channel because I left Audacity recording in Stereo instead of setting it to Mono.

    As for cabling, I hope this image will suffice? I have the UMC404HD plugged into a USB 2.0 port on my laptop, I have the power adapter plugged in though I don't think that's necessary, I have headphones in the jack under the "Phones" knob, and I got an XLR microphone in Input 1.
    Attached Images Attached Images