Help!! Switch 6 doesn’t control vocal effects on play electric!

  1. #1 by Ian Kelosky on 02-24-2018
    Ian Kelosky's Avatar
    Posts: 1

    Help!! Switch 6 doesn’t control vocal effects on play electric!

    I have the Play electric and a switch 6.
    I have everything updated, and as it should be, but the switch 6 won’t work on vocal effects when I assign any button to any effect. It works perfectly for all guitar effects, looper, turning on hit, changing presets, changing keys, everything, but does absolutely nothing when I assign it to control vocal delay, for example, but NONE of the vocal effects respond to it.
    I’ve read the manual, and I am 99% sure i have everything set up right.
    What am I missing??? I specifically got this whole set up to be able to run vocal effects properly.
    Please help!!
    Thank you!
  2. #2 by Spencer Larsen on 02-27-2018
    Spencer Larsen's Avatar
    Posts: 406
    Hey Ian,
    I'm able to control vocal effects on PlayElectric with a Switch-6 here, so I know it definitely is possible... Question time!

    You're updated, right? To build 31? You can check this in the rightmost tab of the "Setup" menu.

    Are you using a TRS cable to connect your Switch-6? A TS cable (guitar cable) won't do the job.

    Do you have the preset levels for the respective vocal effects turned up in the "Vocal FX" menu? The level there is what you'll hear when the Switch-6 toggles them on.

    Do you have the global levels for the respective effects turned up in the "Mix" menu? There are "Harmony" and "Delay/Reverb" global parameters there that'll need to be up.

    Spencer Larsen
    Engineer, Testing
    TC-Helicon,
    MUSIC Group
    Our Support Team is always available for more urgent assistance.