No Level Indicator

  1. #1 by Chad Jacoby on 02-14-2018
    Chad Jacoby's Avatar
    Posts: 3

    No Level Indicator

    I just bought VLTouch 2 used and all seems to work fine. Updated firmware. I'm using a Shure Beta 87A condenser mic and the mic setting is condenser.

    Trying to follow video manuals but in the 2nd one about connections, I tried to set mic level input as Craig did and I do not see any level indicators except for when input level control knob is turned all the way and it's just blasted feedback at that point.

    I hear vocals just fine but I want to be able to confirm via level indicator.

    Can someone please advise?

    Thanks!
  2. #2 by Spencer Larsen on 02-22-2018
    Spencer Larsen's Avatar
    Posts: 455
    Hey Chad,
    First I should ask if your mic input on the right side of the Touch 2 is turned up? There's a little dial on the side of the Touch 2, and with it at its minimum position, you can still hear what's coming in the mic but the LEDs will not light up yet. You need to get pretty loud, so turn up the mic gain and see if that will make the input LEDs light up? What you're looking for is three little LEDs (green, yellow, red) just to the left of the "INPUT" text in the top-right corner of the screen.

    Spencer Larsen
    Engineer, Testing
    TC Helicon,
    MUSIC Tribe
    Our Support Team is always available for more urgent assistance.
  3. #3 by Cecilie Kaasgaard on 02-23-2018
    Cecilie Kaasgaard's Avatar
    Posts: 100
    Hey Chad & Spencer, my VLT2 is the same - the input level dial has to be touching on max before my baseline singing level registers a green dot on the LED. At this point if I sing any louder it'll distort in the headphones (I haven't been able to test the main outputs) and hit orange/red with little or no volume increase from my voice. If I set the input to a nice level in the headphone output, it's too low to register on the LEDs at all. So Chad unless you get no level indicator even with the dial cranked (remember, it's an input gain dial, not an output/volume dial) it's probably acting normal, even if it seems strange. (I'd personally prefer the input LED to register green on all input to make sure there wasn't a glitch or issue, but that's another discussion : )

    Cecilie Kaasgaard
    No longer work in support but I still know a bit about all this stuff!

    Like me? Like my artist facebook-page!