Harmony Singer 2 Issues [Resolved]

  1. #31 by Angelo Santilli on 2 Weeks Ago
    Angelo Santilli's Avatar
    Posts: 1

    I'm On My 3rd One...

    I returned my first one after it embarrassingly crapped out at 2 different gigs. I returned it and got another one which also acted up at 2 more gigs. Shame on me, I guess, but I really do love the ease-of-use of the Harmony Singer 2, so I am on unit #3. So far, so good... I have used it at 4 shows, and it has worked beautifully! I will admit, I am still uneasy about the Harmony Singer's reliability, and welcome a "fix" asap, but so far, so good.

    I will keep you posted if there any changes...

    ... Angelo
  2. #32 by Samuel Desnoulez on 2 Weeks Ago
    Samuel Desnoulez's Avatar
    Posts: 2

    Same issue here

    Hi everyone, this is Sam from France.

    To keep this short:

    Brand new HS2 bought on eBay in the U.S. Pedalboard with MXR MC403 Power System, passive electric guitar plugged straight into the HS2, singing in a SM58 to a P.A. and getting the chipmunk-Commodore64 effect instead of a great choir. Like other users, it doesn't happen all the time, but the random of it makes it untrusty on stage.

    I'm waiting for a firmware update to use it and blow the audience with cool backng vocals.
    Merci.
  3. #33 by Edward James on 2 Weeks Ago
    Edward James's Avatar
    Posts: 2
    Spencer-

    Do you have a time frame of when the firmware will updated to correct this issue ?
  4. #34 by Brock Meeks on 1 Week Ago
    Brock Meeks's Avatar
    Posts: 2

    Distortion, Sound Wavering

    I'm having similar issues with my Harmony Singer 2. Any time the voice volume gets above a certain threshold it's as if the sound is "gated" for reason and the quality erodes quickly, is not present at all (the harmony voices) or is crackling and distorted.

    Adding insult to injury, I fear when (if) a firmware fix is found for this it will do me no good because I can't get the Harmony Singer 2 to connect to the Voice Support software on my Mac (the software refuses to recognize that a device is plugged into the USB port, though it always says "no MIDI device found" and of course the HS2 isn't a straight midi device. So that's strike 2 against what, in theory, is a fine little piece of music equipment.

    What I want to know is how all those demos I saw of this thing were made if so many of us are having issues with it. Did a bad batch come out of the factory? Time for a RECALL I would say.
  5. #35 by Cecilie Kaasgaard on 1 Week Ago
    Cecilie Kaasgaard's Avatar
    Posts: 92
    - Brock Meeks wrote View Post
    Adding insult to injury, I fear when (if) a firmware fix is found for this it will do me no good because I can't get the Harmony Singer 2 to connect to the Voice Support software on my Mac (the software refuses to recognize that a device is plugged into the USB port, though it always says "no MIDI device found" and of course the HS2 isn't a straight midi device.
    Hi Brock, can't help with the firmware issue regarding the HS2 but this FAQ might help you get it to connect to voicesupport on Mac. Make sure voicesupport is force closed before you follow the instructions.

    Cecilie Kaasgaard
    No longer work in support but I still know a bit about all this stuff!

    Like me? Like my artist facebook-page!
  6. #36 by Brock Meeks on 1 Week Ago
    Brock Meeks's Avatar
    Posts: 2
    - Cecilie Kaasgaard wrote View Post
    Hi Brock, can't help with the firmware issue regarding the HS2 but this FAQ might help you get it to connect to voicesupport on Mac. Make sure voicesupport is force closed before you follow the instructions.
    Thanks ... tried all those steps, too, no luck. I'm sure there's something I've missed, so I'll keep trying.
  7. #37 by Kelly Raines on 1 Week Ago
    Kelly Raines's Avatar
    Posts: 1

    Output crackle because insufficient power?

    I've been having problems with my HS2 making a low level crackling static.
    I've not been able to replicate at home and live its been somewhat inconsistent but happening most often--maybe even only at-- a particular venue that has obvious electrical problems.

    I'm testing it today with a dedicated power supply and again all is working properly.

    I use a Truetone 1 SPOT that should have enough juice but with inconsistent or dirty electric, maybe not. I can easily add a dedicated power supply for the HS2.

    Is crackling static a possible effect of dirty electrical?
  8. #38 by Cecilie Kaasgaard on 1 Week Ago
    Cecilie Kaasgaard's Avatar
    Posts: 92
    - Brock Meeks wrote View Post
    Thanks ... tried all those steps, too, no luck. I'm sure there's something I've missed, so I'll keep trying.
    I'm gonna go ahead and assume you've tested the USB cable to make sure it's not faulty? Also the basics, the pedal has to be on while you connect of course. does it show in the midi devices thingy of the mac? (I don't have a mac now so I can't remember what the section is called ha, Sorry!) have you had any opportunity to maybe try it with a different computer/maybe a PC to make sure it's narrowed down to the pedal? If none of this works it sounds like there might be an issue with the USB port, that should be fixed by a service centre, support can help you out with that.

    Cecilie Kaasgaard
    No longer work in support but I still know a bit about all this stuff!

    Like me? Like my artist facebook-page!
  9. #39 by Rastislav Makys on 1 Week Ago
    Rastislav Makys's Avatar
    Posts: 3
    - Brock Meeks wrote View Post
    Thanks ... tried all those steps, too, no luck. I'm sure there's something I've missed, so I'll keep trying.
    hi Brock, HS2 needs to be powered by AC adaptor or on batterries,USB port will not power the device... just my 2 cents.
    Rasti
  10. #40 by Rastislav Makys on 1 Week Ago
    Rastislav Makys's Avatar
    Posts: 3
    hi,
    just to increase number of affected users, also reporting/having the same issue. as is not an adapter issue, but audio input, please note that HS2 input is feeded by TC polytune3 output, guitar to TC PT3 input on my pedalboard. mic used ShureSM58
    Rasti