macOS Sierra and Midas Venice F series Firewire driver

  1. #11 by Matt Burgess on 03-27-2017
    Matt Burgess's Avatar
    Posts: 1
    Can it really be that difficult to fix this thunderbolt adapter issue? Thinking of selling this board as it's pretty useless to me now!
  2. #12 by Chase McKnight on 03-30-2017
    Chase McKnight's Avatar
    Posts: 354
    Hi Jesse,

    Apologies for the delay - I’m not on our forums as regularly as I used to be, as I’ve changed positions within the company.

    Because the Midas VeniceF Series are legacy products, our software team aren’t proactively updating drivers. The most recent driver for our VeniceF Series (v4.2.1) supports up to Mac OS X 10.11.x.

    If you’re experiencing issues, please contact our CARE team at CAREente@music-group.com

    Moving forward, you can reach me any time at (425) 248-5705 or via email at ENTESolu3AMER@music-group.com.

    Chase McKnight
    Manager, Solutions
    MUSIC Group
    MIDAS
  3. #13 by Robert Lofgren on 03-30-2017
    Robert Lofgren's Avatar
    Posts: 4,832
    - Phil Bolland wrote View Post
    Hi Michael

    Just bought an f16 and having exact same problem. Device not found when connecting to thunderbolt with an apple converter on my mac book pro. Really frustrating! Did you get yours to work?

    Midas - is there a workaround?

    Thanks!
    My apogee ensamble firewire does not work with sierra but I found a solution to make it work.

    http://www.macworld.co.uk/how-to/mac...otless-3638975

    Perhaps this will work for you too.

    __________________________________________________ _______________________

    For official technical and warranty support for your product you should contact the support team through their CARE department. You can contact CARE by phone at (+1) 702-963-1300 for the US and Canada and (+44) 1562 732290 in Europe.

    You can also contact CARE support via email at CARECREA@music-group.com. They strive to respond to emails within 24-48 hours during normal business hours, but please be patient if it takes longer due to the volume of emails they receive.


    Robert Lofgren
    Volunteer Forum Community Moderator
  4. #14 by Andreas Markusen on 08-07-2017
    Andreas Markusen's Avatar
    Posts: 3
    - Chase McKnight wrote View Post
    Hi Jesse,

    Apologies for the delay - I’m not on our forums as regularly as I used to be, as I’ve changed positions within the company.

    Because the Midas VeniceF Series are legacy products, our software team aren’t proactively updating drivers. The most recent driver for our VeniceF Series (v4.2.1) supports up to Mac OS X 10.11.x.

    If you’re experiencing issues, please contact our CARE team at CAREente@music-group.com

    Moving forward, you can reach me any time at (425) 248-5705 or via email at ENTESolu3AMER@music-group.com.
    Hi,
    Is there any updates on this?

    Writing you a mail won’t solve the issue mentioned above, due to that we talk about a “out-dated” driver for Mac. I want to use my Midas venice f16 with my Macbook pro installed with Sierra, but is receiving the “No devices found” error, when I open the FW-program. When I look at the “Firewire Driver for Mac” file details on your Midas download page, then I see a file which has not been updated since 2011. (6 years)
    • Conclusion: I´m sitting with a half useless mixer and I will also not be able to resell it because the next end-user will also not be able to use it fully.

    The troubleshoot manual says following:
    No devices found
    Important:
    The VeniceF must be switched off before the FireWire cable is connected to it.
    If you see a ‘no devices found’ message, it means that the PC cannot detect a FireWire
    device. To clear the message, do one of the following:
    • Connect the VeniceF to the PC.
    • If the VeniceF is already connected to the PC, check that the connections are good.
    This does not help the end-user in this case. Due to that the error is driver related.

    Did anyone else confirm Robert Lofgren`s solution above with turning off SIP/System Integrity Protection as solving the issue?
  5. #15 by Robert Lofgren on 08-08-2017
    Robert Lofgren's Avatar
    Posts: 4,832
    You only need to turn off the protection while you perform the installation. When everything is finished and hopfully working you can turn it on again. I was so happy that this worked for my Ensamble firewire.

    Chase has moved to a different department within the company and may not reply.

    __________________________________________________ _______________________

    For official technical and warranty support for your product you should contact the support team through their CARE department. You can contact CARE by phone at (+1) 702-963-1300 for the US and Canada and (+44) 1562 732290 in Europe.

    You can also contact CARE support via email at CARECREA@music-group.com. They strive to respond to emails within 24-48 hours during normal business hours, but please be patient if it takes longer due to the volume of emails they receive.


    Robert Lofgren
    Volunteer Forum Community Moderator
  6. #16 by Andreas Markusen on 08-08-2017
    Andreas Markusen's Avatar
    Posts: 3
    - Robert Lofgren wrote View Post
    You only need to turn off the protection while you perform the installation. When everything is finished and hopfully working you can turn it on again. I was so happy that this worked for my Ensamble firewire.

    Chase has moved to a different department within the company and may not reply.
    Hi Robert Lofgren,
    I didn’t expect to get a reply so fast. Thank you for the fast reply.

    Just to verify/re-confirm. You have not tested, if turning off SIP will resolve the issue for the FW driver for Midas Venice F series?

    I had an interesting observation as I installed the Firewire driver above with SIP on. My Macbook said that the installation was successful. Did your installation for the Apogee Ensamble Firewire also give you a successful message for the installation, when SIP was on?

    I have tried contacting Music-Group support to confirm, if there was any plans about Firmware driver updates for Midas Venice F and I got an indirect “no”. They mentioned that I should try testing the mixer from another device, to be sure that the mixer was actually working (I could example do it from my Windows PC). They also didn’t want to comment on the SIP idea.
  7. #17 by Andreas Markusen on 08-11-2017
    Andreas Markusen's Avatar
    Posts: 3
    - Robert Lofgren wrote View Post
    You only need to turn off the protection while you perform the installation. When everything is finished and hopfully working you can turn it on again. I was so happy that this worked for my Ensamble firewire.

    Chase has moved to a different department within the company and may not reply.
    Hi Robert,
    Thank you for the tip above. I have now tested the above with turning SIP off, install firmware and SIP on again. I´m now able the see the mixer with the Midas Control software.

    I now need to test if the mixer is fully functional
  8. #18 by Konrad Ilke on 11-06-2017
    Konrad Ilke's Avatar
    Posts: 2
    - Andreas Markusen wrote View Post
    Hi Robert,
    Thank you for the tip above. I have now tested the above with turning SIP off, install firmware and SIP on again. I´m now able the see the mixer with the Midas Control software.

    I now need to test if the mixer is fully functional
    I've tried the tip above, turned sip off, installed the latest driver osx 4.2.1 and my midas fw control center is still showing "no device found"

    I've been trying to get this up and running for 10 hours now, reading old posts but still no success...
  9. #19 by Allen Cato on 02-09-2018
    Allen Cato's Avatar
    Posts: 2
    Hello, i purchased a Midas Venice F24 not even a year ago and the drivers are already outdated and preventing me from moving forward with DAW Software. Checking here to see if any Drivers Update plans are in the future.
  10. #20 by Rob Merget on 3 Weeks Ago
    Rob Merget's Avatar
    Posts: 1

    macOS Sierra and Midas Venice F series Firewire driver

    Hi, i can confirm what Robert wrote.
    Turn of SIP, instal driver, conect the desk and it works!
    Afterwards you can turn SIP on again and it still works.
    Make sure to uninstal the driver before.
    Tested and approved on MacBookPro Mid 2015 2,5 GHz i7, Sierra 10.12.6 (with Thunderbolt-FW800 Adapter)
    also on Mac Mini Late 2012 2,3 GHz i7, High Sierra 10.13.4
    Really made my day, thanx to Robert
    Happy Mixing, Rob